先日、protoolsの動作が非常に遅くなりました。
起動に20分程度かかり、起動後も一度のクリックが反映されるまで5分近くかかるといった、
とても使えたものではない状態に陥りました。
あっけない事で解決したので、紹介します。


スポンサードリンク

パソコンにSDカードがささっていた

USBハブにさしていたSDカードを、抜いただけで改善しました。

なにか問題が起こった場合、原因の切り分けのために、必要のない機器は取り外す事は常識でしたが、盲点でした。

一応メモために、どの症状だったか記載しておきます。


起動が遅い

  1. まずは、この画面で数分かかります。
    2017-08-07_18h46_08
  2. 次に「データベースの初期化中」で数分
    2017-08-07_18h46_13
  3. プラグインの読み込みに数十分(プラグインが多い場合)
    2017-08-07_18h46_13
  4. なんとか起動しても、すぐに「応答なし」
    2017-08-07_18h48_13

注意点としては、「アカウントエラー」でも「プレイバックエンジン」でもない点で、
ただ単純に動作が遅いだけという点です。

試したこと

  1. 初期設定ファイルの削除
  2. iLokのドライバの更新(最新だった)
  3. 現在使用していないオーディオドライバの削除
  4. Cドライブのディスクチェック
  5. Protoolsの再インストール

以上の通りに、ベーシックな対処はしましたが、一向に改善しませんでした。
サブスク解約しようかなとも思いましたが、一応海外のサイトも検索してみる事にしました。


仮想ドライブツールはProtoolsには相性が悪い

見出しの通りの文章を見つけました。
DAEMON TOOLなどの仮想ドライブツールとProtoolsは非常に相性が悪いらしく
様々な問題が起こるそうです。

しかし、うちのPCも仮想ドライブで構成しているのですが、
以前までは全く問題なく動いていました。
ある日突然、何もしていないのに動作が遅くなったのです。


ドライブにCDやDVDが入っていると問題が起きる事がある

CDやDVD、BDなどがドライブに入ったままだと、
protoolsの挙動がおかしくなる事があるようです。
しかし、当時僕のPCのCDドライブは空の状態でした。
そこで、もしかして?と思い、「マイコンピュータ」を覗いてみました。


リムーバブルディスクが原因だった

実は、SDカードはPCに挿入されていなかったのですが、下記の画像のように
リムーバブルディスクが存在しています。
2017-08-07_19h00_48

他になすすべがありませんでしたので、右クリックをして「取り出し」を行いました。
依然、リムーバブルディスクの表示は消えませんが、Protoolsを起動してみました。


いつも通り起動した

いつも通り、1分もかからずに起動してくれました。
それ以外の動作も、以前と全く同じです。
解決です。


SDカードの挿入が原因ではないと思う

今までスタジオで、何度もprotoolsセッションやデータをフラッシュメモリに移すシーンを見てきました。しかし、僕と同じような症状は出ていなかったはずです。
我が家がWindowsだからでしょうか?
しかし、検索しても似たような症状は見つかりませんし
かなり重大な欠陥なので、Avidからなんのアナウンスもないのは変です。

仮想ドライブツールとSDカードの合わせ技の不具合

ためしに、仮想ドライブにISOをマウントしてみましたが、不具合は発生しませんでした。
断定はできませんが、仮想ドライブツールの使用+SDカードの挿入(履歴?)
によって生じるのではないかと想像しています。


スポンサードリンク

まとめ

今の所再現性はありませんが、同じような症状がありましたら試してみてください。
初期設定ファイルの削除や、protoolsの再起動ほどダメージは大きくないはずです。

じゃ。